Microsoft resolved the issue they were having and email is flowing normally again.
Posted Jan 23, 2026 - 09:54 PST
Monitoring
Microsoft is making progress but still working to resolve the issue with Office 365 email. Some of the delayed emails that are in our out-going queue have gone out but there are still some waiting to be delivered.
Posted Jan 22, 2026 - 18:11 PST
Investigating
Microsoft is having issues. * Email sent to people using Microsoft on-line email is being delayed or not going through at all. * The Office 365 admin portal is also down so we have not been able to get an official status. I have another tool that shows other Office 365 customers are having the same issue.