LiquidFiles Secure Attach is down

Resolved

LiquidFiles secure file attach is back up and running normally.
Posted May 02, 2026 - 14:41 PDT

Monitoring

The vendor has a fix in place for the LiquidFiles secure file send. We are monitoring for additional issues.
Posted May 01, 2026 - 21:17 PDT

Investigating

LiquidFiles secure attachments is current down - we are currently investigating.
Posted May 01, 2026 - 08:15 PDT