The issue was resolved and things should be back to normal.
Posted Feb 24, 2026 - 11:31 PST
Investigating
There are a small number of students that can't login to Chromebooks, access Google Classroom, and/or are getting errors logging into ClassLink this morning. We are investigating.
Posted Feb 24, 2026 - 10:03 PST
This incident affected: Google Workspace Apps (Google Apps Classroom), ClassLink (ClassLink My Classes, ClassLink Analytics, ClassLink My Files, ClassLink Roster Server, ClassLink Active Directory Integration), and Curriculum Apps.