District Chromebooks not connecting to wifi

Postmortem

The underlying issue seems to stem from changes that Microsoft made in the way Windows server 2025 responds to UDP based network protocols. such as Radius/NPS, and DHCP. The Chromebooks on chrome OS v138 are not tolerant of the changes that are creating variable response times that are now in Windows server 2025. We had to downgrade the Chromebook radius authentication process used for the wifi connection to a Windows 2019 Radius/NPS server to get the chromebooks back to reliably connecting to wifi.

We tried multiple network card setting changes on the Window 2025 NPS server, and changed to a different model network card. None of the changes that we tried on the Windows 2025 server, resolved the issue for the Chromebooks. The Windows laptops are working fine on the Windows 2025 Radius/NPS server.

We are monitoring Microsoft patches as they come out over the next several months to see if they release a fix for the Windows 2025 server to allow the Chromebooks to work. There is also a possibility that Google adds a fix to the Chrome LTS v144, or v150 as they are release over the next six months.

For now we are running with the Chromebook wifi Radius/NPS authentication process running through a Windows 2019 server.

Posted Jan 13, 2026 - 09:49 PST

Resolved

The work around that we put in place on Thur 1/8 about noon resolved the issue with the Chromebook wifi connections.
Posted Jan 13, 2026 - 09:31 PST

Update

The work around that we put in place Thur 1/8 about 12:45p appears to have fixed the wifi issue with the Chromebook.
Posted Jan 09, 2026 - 10:57 PST

Update

We put in a second work around for the Chromebooks about 12:45p this afternoon. This is getting much better results. I am hopeful we are close to normal.
Posted Jan 08, 2026 - 14:34 PST

Update

The change that we made last night looked promising but failed this morning under heavier load. We have another work around in place at ITS and the HS the looks promising. We may need to put the work around in place at the middle and elementary school servers but think they may be ok with the changes from last night since they are on a lighter server load.
Posted Jan 08, 2026 - 10:05 PST

Monitoring

Additional setting changes have been made to all the school servers. It seemed to work well under light load. Hopefully it will work well under heavy load.
Posted Jan 07, 2026 - 19:36 PST

Update

The last change had a small improvement but did not fully resolve the issue.
Posted Jan 07, 2026 - 14:31 PST

Identified

We have implemented another change that may have fixed the issue for some sites.
Posted Jan 07, 2026 - 12:08 PST

Investigating

Chromebooks are having connectivity issues this morning again. We are investigating.
Posted Jan 07, 2026 - 09:34 PST

Monitoring

The server changes have been applied. Things should be back to close to normal.
Posted Jan 06, 2026 - 17:56 PST

Identified

The issue has been identified in the recently upgraded Windows 2025 server network card driver. We are working on implementing changes to fix the issue. Chrome books should start connecting reliably to SKAccess as we work through the servers.
Posted Jan 06, 2026 - 12:55 PST

Update

The chrome books are intermittently connecting. They are randomly having trouble getting network IP addresses. We are still looking for the cause of the issue.
Posted Jan 06, 2026 - 09:27 PST

Investigating

We are working to track down the issue the the Chromebooks.
Posted Jan 05, 2026 - 09:51 PST
This incident affected: School Networks and Services (ITS and Data Center, South Kitsap High School including the Armory, Discovery Alt. High School and Madrona Heights, Cedar Heights Middle School, John Sedgwick Middle School, Marcus Whitman Middle School, Explorer Academy, Burley Glenwood Elementary, East Port Orchard Elementary, Hidden Creek Elementary, Manchester Elementary, Mullenix Ridge Elementary, Olalla Elementary, Orchard Heights Elementary, Sidney Glen Elementary, South Colby Elementary, Sunny Slope Elementary, District Office and Transportation, Facilities Services, Food Services and Warehouse).