Server outage

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 13:27 PDT

Monitoring

The issue appears to be resolved and services are working normally. We will monitor throughout the morning
Posted Jul 10, 2025 - 07:54 PDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 10, 2025 - 07:05 PDT

Identified

We have several servers down this morning that are affecting multiple services. We have identified the issue and are working to resolve the issue.
Posted Jul 10, 2025 - 06:26 PDT
This incident affected: Skyward/Qmlativ, Internet / K-20, Email, Office and Operational Apps and School Networks and Services (ITS and Data Center).