CenturyLink/Lumen has identified the issue but anticipates our phone service won't be restored until sometime tomorrow.
Posted Jan 27, 2026 - 15:30 PST
Identified
There is a problem between us and our phone service provider. The phone service provider has identified a problem with the phone line, and is trouble shooting.
Posted Jan 27, 2026 - 10:16 PST
Investigating
We are currently investigating the issue effecting both incoming and outgoing calls.